首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX 提问指南
V2EX  ›  问与答

android 中 gradle 依赖问题

  •  
  •   niuzhaojie · 95 天前 · 276 次点击
    这是一个创建于 95 天前的主题,其中的信息可能已经有所发展或是发生改变。
    同一个项目中有 app module A 和 library B 和 library C,A 需要依赖 B、C,B、C 则相互独立,现在有一个第三方依赖库 D,A、C 需要依赖 D 的 2.0 版本,但是 B 只能依赖 D 的 1.0 版本,请问这样的依赖关系,依赖管理怎么做?
    3 回复  |  直到 2019-09-03 19:03:27 +08:00
        2
    nnnToTnnn   94 天前
    不好意思,看错了,你这个依赖关系有点蛋疼,无解,如果 D 的 2.0 版本 和 D 的 1.0 版本有冲突的话
        3
    niuzhaojie   94 天前
    @nnnToTnnn 只能同意升级 D 到 2.0 了
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2351 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 25ms · UTC 13:33 · PVG 21:33 · LAX 05:33 · JFK 08:33
    ♥ Do have faith in what you're doing.