V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
moqsien
V2EX  ›  推广

🔥🔥🔥Version-Manager 增加对 Android SDK 的支持。

  •  
  •   moqsien · 48 天前 · 609 次点击
    这是一个创建于 48 天前的主题,其中的信息可能已经有所发展或是发生改变。

    项目地址https://github.com/gvcgo/version-manager

    文档地址https://github.com/gvcgo/version-manager/blob/main/docs/readmeCN.md

    Version-Manager 是一个通用的 SDK 版本管理器。目前能够管理 40 多种语言的 SDK 和工具,例如 Java, Go, Node.js, Deno, Bun, .Net, Python, PyPy, PHP, Rust, Kotlin, Scala, Groovy, Flutter, Julia, Zig, V, Typst, Android SDKs 等等。

    非 Docker 实现,全部本地安装,轻量好用。

    主要功能:一键安装某个版本,切换版本,终端 session 模式(即在虚拟终端中使用某个版本,退出虚拟终端后不影响原来版本),卸载某个版本,一键设置环境变量等等。

    适用人群

    • 需要在多版本之间切换的同学;
    • 多语言开发者;
    • 经常折腾的同学;
    • 喜欢尝新的同学;
    • 有洁癖的同学;
    • 和我一样懒,不想去搜索找资源的同学;

    VMR 特色: 除了各种语言的 SDK 版本管理外,VMR 还有其他方便的功能:

    • 一键安装 Neovim ,以及 Neovim 经常用到的一些插件,例如 lazygit ,fd ,fzf ,tree-sitter 等等;
    • 一键安装 VSCode
    • 简化的命令来打造用 VSCode 加 Flutter 开发安卓 APP 的环境,无需安装 Android Studio ;
    • 一键安装跨平台的终端录屏工具 asciinema(acast 命令),写文档必备利器;
    • 更多特色,详见项目主页;
    2 条回复
    AoEiuV020JP
        1
    AoEiuV020JP  
       48 天前 via Android
    安卓 sdk 感觉就没有切换版本的必要了吧,本身就支持多版本共存使用,你这里的安装能和官方 studio 安装混用吗?感觉可能有冲突,
    moqsien
        2
    moqsien  
    OP
       48 天前
    @AoEiuV020JP 主要针对不安装 Android Studio 的情况下,直接使用 VSCode+Flutter+Android SDK 进行开发的情况。

    如果你使用 AS ,那就没必要了。
    关于   ·   帮助文档   ·   博客   ·   API   ·   FAQ   ·   实用小工具   ·   5739 人在线   最高记录 6679   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 23ms · UTC 01:58 · PVG 09:58 · LAX 18:58 · JFK 21:58
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.