V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
honeygeek
V2EX  ›  NAS

想吐槽 pve 直通核显怎么这么麻烦

  •  
  •   honeygeek · 40 天前 via iPhone · 1480 次点击
    这是一个创建于 40 天前的主题,其中的信息可能已经有所发展或是发生改变。

    一晚上没有弄好。pve7.4 的版本,cpu 是 amd 5700u 。按教程走完后,win10 系统里面,设备管理-显示适配器 能看到 AMD Radeon(TM) Graphics ,但是是黄色的,提示:“由于该设备有问题,WIndows 已将其停止。(代码 43 )”。

    不知道哪里没操作对,求助各位大佬!

    13 条回复    2024-06-06 16:35:29 +08:00
    tcpdump
        1
    tcpdump  
       40 天前
    提取核显 vBIOS 啊,BIOS 一定要用 SeaBIOS

    https://imgur.com/n2jvKTt

    https://imgur.com/VmWrook
    ltkun
        2
    ltkun  
       40 天前 via Android
    cpu 是 host 模式了吗
    honeygeek
        3
    honeygeek  
    OP
       40 天前 via iPhone
    @tcpdump 我加来试下 感谢
    honeygeek
        4
    honeygeek  
    OP
       40 天前 via iPhone
    @ltkun 是 host 模式
    conglovely
        5
    conglovely  
       40 天前
    同 PVE7.4 ,CPU 是 I3-8100T 按教程直通给 WIN10 或是群晖,虚拟机都启动不了
    cleanery
        6
    cleanery  
       40 天前
    我之前搞好了直通, 但是虚拟机里重启有可能丢失, 重启整个 pve 后才恢复, 干脆不装 pve 了
    NOneKnowYeah
        7
    NOneKnowYeah  
       40 天前
    esxi6.7 虚拟 win10 卡卡的,有的时候操作要等 3 秒才会响应,已经分配了 8 个 cpu 了,弄核显直通可以缓解吗
    JRay
        8
    JRay  
       40 天前
    我折腾独显直通也坑多得很,通过去了,但是不能装驱动
    ltkun
        9
    ltkun  
       40 天前
    其实不建议这种只用 现在独显已经很便宜了 搞快 nvidia 的 1060 以上的显卡就行 玩 vgpu 民用卡最高支持到 2090 系列 当然不折腾就直接上 p4 p40 p100 这种 几百大洋都是 我的 intel 核显直通给了 macOS 但是也不经常开那台机器 主要插了独显外加十几块硬盘太好电了哈
    honeygeek
        10
    honeygeek  
    OP
       40 天前 via iPhone
    @conglovely 我也是现在宿主 pve 也启动不了咯。头皮麻了,报错“volume group pve not found cannot process volume group pve” ,不知道这个报错是不是按教程删 local-lvm 影响的,把 ssd 挂载进来,昨晚都好好的重启没问题,今天早上重启就启动不了咯。之前 pve 用了两三年停稳的,第一次搞来启不来。
    honeygeek
        11
    honeygeek  
    OP
       40 天前 via iPhone
    @NOneKnowYeah 我也没有过,以前用 5600G 做的虚拟化 win10 挺流畅的,也没搞显卡直通。
    coldle
        12
    coldle  
       40 天前 via Android
    感觉一堆坑,所以我 pve on 5600g 一直当 5500 用,win 虚机不打游戏 rdp 虚机够用了,linux 开 virtio-gl 假装吃一下核显(实际基本用不上)
    XXOO133
        13
    XXOO133  
       40 天前
    PVE+win 的核显直通是有点问题,我 10400T ,从 7.X 到 8.X ,直通给黑裙完全没问题,WIN 核显直通倒是可以,也能正常驱动,但是用一段时间 WIN 就完全卡死,虚拟机怎么都关不了(和楼上有位兄弟说得一样),PVE 日志报错,得重启整个 PVE 才行。找了很长一段时间解决方案,有老外在论坛上说装数据中心版的 win server2019 正常,楼主如果愿意折腾可以试试,希望能反馈下效果。
    关于   ·   帮助文档   ·   博客   ·   API   ·   FAQ   ·   实用小工具   ·   4755 人在线   最高记录 6679   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 30ms · UTC 09:42 · PVG 17:42 · LAX 02:42 · JFK 05:42
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.