首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX  ›  信息安全

除了 https (443),ssh(22)會受到 heartbleed 影响嗎?

  •  
  •   snx · 2014-04-09 15:08:15 +08:00 · 2723 次点击
    这是一个创建于 1990 天前的主题,其中的信息可能已经有所发展或是发生改变。
    3 回复  |  直到 1970-01-01 08:00:00 +08:00
        1
    clino   2014-04-09 15:35:20 +08:00
    貌似openssh-server openssh-client对于libssl都有依赖吧,不知道会不会有影响

    $ apt-cache show openssh-server|grep ssl
    Depends: libc6 (>= 2.15), libcomerr2 (>= 1.01), libgssapi-krb5-2 (>= 1.10+dfsg~), libkrb5-3 (>= 1.6.dfsg.2), libpam0g (>= 0.99.7.1), libselinux1 (>= 1.32), libssl1.0.0 (>= 1.0.0), libwrap0 (>= 7.6-4~), zlib1g (>= 1:1.1.4), debconf (>= 1.2.0) | debconf-2.0, openssh-client (= 1:5.9p1-5ubuntu1), upstart-job, libpam-runtime (>= 0.76-14), libpam-modules (>= 0.72-9), adduser (>= 3.9), dpkg (>= 1.9.0), lsb-base (>= 3.2-13), procps
        2
    akann   2014-04-09 15:39:41 +08:00
    这里有个讨论,openssh不受影响:
    http://undeadly.org/cgi?action=article&sid=20140408063423
        3
    clino   2014-04-09 15:48:43 +08:00
    我也搜到一个:
    https://serverfault.com/questions/587414/do-i-need-to-replace-keys-for-openssh-in-response-to-heartbleed
    Do I Need to Replace Keys for OpenSSH in Response to Heartbleed?

    另外找到一个检测漏洞的脚本:
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   997 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 18ms · UTC 18:42 · PVG 02:42 · LAX 11:42 · JFK 14:42
    ♥ Do have faith in what you're doing.