首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX  ›  程序员

再吐槽 linux 的版本依赖

  •  
  •   cxshun · 2015-06-24 14:53:28 +08:00 · 11168 次点击
    这是一个创建于 1580 天前的主题,其中的信息可能已经有所发展或是发生改变。
    今天早上,由于维护docker环境 ,要安装一个叫Image magick的图片处理工具,这家伙最新版本为6.9.1-6,在安装它之前需要先装delegates,即类似的第三方处理工具,由它去处理png,jpeg等等的啥东西。
    就是这一堆东西: http://www.imagemagick.org/download/delegates/

    在这个Image magick上花了接近大半天的时间,主要是configure时死活认不出libpng,但实际上已经装完了。
    后来实在没办法,硬是换回了旧版本6.9.1-1完事。

    有时候,我会想,这些源代码编译软件的存在,就是为了折磨我们吗?这版本依赖的存在,相比windows和mac的一个包搞定的,简直是坑爹得不行。

    遇到这样一种源代码安装,并且版本依赖非常强的软件,你们的看法是怎样的?

    PS:曾经遇到过一个需要源码编译的软件,它依赖的软件,相关0.0.1都编不过,从那个时候开始,遇到需要编译安装的软件,我就觉得好日子好像又到头了。
    PS2:不要说apt-get和yum哈,那两个家伙确实不错,但问题是很多源代码安装的软件不在那里面啊。
    第 1 条附言  ·  2015-06-25 14:21:48 +08:00
    经过各位V友的指正,我用源代码跟windows下的msi或mac下面的pkg或app比较是不对的,两个是完全不同的东西,确实,应该用apt、yum等包管理进行比较。多谢各位的指定。

    看回复,好多人都推荐用包管理,看来用源代码安装确实是一个不便的做法,以后也会尽量避免,毕竟有可能会遇到一些依赖性的问题,花费大量的时候也不划算。
    104 回复  |  直到 2015-11-29 03:22:54 +08:00
    1  2  
        101
    wych   2015-06-26 10:26:38 +08:00
    @benjiam 那谁解决呢?开发者还是维护者?
        102
    benjiam   2015-06-26 10:38:19 +08:00
    @wych 当然是开发者。 开发者提供可以直接使用的二进制版本。但是随之带来的问题,如何保证二进制里面没有其他东西。 如何定制可以直接使用的二进制。
        103
    bhzhu203   2015-06-26 16:58:39 +08:00
    看config.log,这里才有具体提示
        104
    Axurez   2015-11-29 03:22:54 +08:00
    要不你试试在 Windows 下编译这个软件是不是更爽。。
    1  2  
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   4165 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 22ms · UTC 07:56 · PVG 15:56 · LAX 00:56 · JFK 03:56
    ♥ Do have faith in what you're doing.