首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX  ›  macOS

OS X el captain (10.11.4) 下装 flarum 用的 PHP 7 报错了

  •  
  •   xjvf · 2016-02-25 11:16:04 +08:00 · 1428 次点击
    这是一个创建于 1270 天前的主题,其中的信息可能已经有所发展或是发生改变。

    目前已有

    $ php -v

    PHP 7.0.3 (cli) (built: Feb 6 2016 03:16:24) ( NTS )
    Copyright (c) 1997-2016 The PHP Group
    Zend Engine v3.0.0, Copyright (c) 1998-2016 Zend Technologies
    with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2016, by Zend Technologies

    $ brew --version
    Homebrew 0.9.5 (git revision ecba1; last commit 2016-02-23)

    $ httpd -v
    Server version: Apache/2.4.18 (Unix)
    Server built: Feb 12 2016 16:50:38

    $ mysql --version
    mysql Ver 15.1 Distrib 10.1.11-MariaDB, for osx10.11 (x86_64) using readline 5.1

    现在的环境出现下面这个错误是咋回事儿

    Notice: Undefined property: stdClass::$data in /Users/my-username/Sites/vendor/flarum/core/src/Http/Controller/ClientView.php on line 326

    需要看我的 httpd.conf 和 httpd-vhosts.conf 吗?

    3 回复  |  直到 2016-02-25 17:56:40 +08:00
        1
    blogcool   2016-02-25 12:29:29 +08:00
    是 php 代码的问题,和 apache 无关吧, Notice 的提示可以关了。
        2
    qqjt   2016-02-25 12:54:37 +08:00
    flarum 不支持 php7
        3
    xjvf   2016-02-25 17:56:40 +08:00
    @qqjt 握了棵草。。。感谢回复
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2049 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 20ms · UTC 10:46 · PVG 18:46 · LAX 03:46 · JFK 06:46
    ♥ Do have faith in what you're doing.