首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX 提问指南
宝塔
V2EX  ›  问与答

Java 关于引用类库多个版本冲突的问题

  •  
  •   codingKingKong · 2017-08-16 15:16:35 +08:00 · 982 次点击
    这是一个创建于 821 天前的主题,其中的信息可能已经有所发展或是发生改变。

    是这样的:

    假如我有 1 个项目 A.

    A 项目里原引用 spring4.3.3 版本, 后因为(假设啊)想要使用 4.5 版本, 需要用到其新特性, 但是老代码对 4.3 有依赖, 4.5 中依赖的部分被废弃了, 这种情况, 大家是怎么处理的呢?

    比如怎么让项目同时兼容两个版本的 spring.
    或者其他灵丹妙药啥的?

    目前尚无回复
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2284 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 21ms · UTC 12:15 · PVG 20:15 · LAX 04:15 · JFK 07:15
    ♥ Do have faith in what you're doing.