首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX 提问指南
Coding
V2EX  ›  问与答

bootcss 的 cdn 挂了,我们的平台也挂了

  •  1
     
  •   ilaipi · 2018-10-14 13:50:21 +08:00 · 2053 次点击
    这是一个创建于 423 天前的主题,其中的信息可能已经有所发展或是发生改变。
    挂了之后我换了 cdn,看 v2ers 推荐用了 loli.net 的,现在看 network,库都能正常加载了。

    但是 js 在执行的时候会报 require is not defined,然后就导致 react 执行不了,整个瘫痪。

    这种情况有点懵,不知道怎么查问题了...
    第 1 条附言  ·  2018-10-14 15:28:07 +08:00
    问题解决了,是我没搞懂 umd 和 cjs,在引用 react 的时候引用了 cjs 的版本,应该引用 umd 的。感谢我的前端兄弟支持
    4 回复  |  直到 2018-10-14 15:19:55 +08:00
        1
    cy97cool   2018-10-14 14:47:26 +08:00
    你可以换回去 自动跳转到 cloudflare 也不是不能用嘛
        2
    cy97cool   2018-10-14 14:47:49 +08:00
    先保证可用 再谈优化
        3
    ilaipi   2018-10-14 14:49:14 +08:00
    @cy97cool 我先改成 cloudflare 也不行才改到 loli 这边,奇怪,感觉就是 polyfill 的问题
        4
    Twinkle   2018-10-14 15:19:55 +08:00 via Android
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2359 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 31ms · UTC 00:37 · PVG 08:37 · LAX 16:37 · JFK 19:37
    ♥ Do have faith in what you're doing.