首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
DAOCLOUD
推荐学习书目
Python Cookbook
Using Google App Engine
推荐下载
Latest Google App Engine SDK
其他兼容技术
AppScale
huangz
V2EX  ›  Google App Engine

在python里可以载入ssl,但gae更新总是提示ssl出错。

  •  
  •   huangz · 2010-12-23 10:46:47 +08:00 · 5879 次点击
    这是一个创建于 3314 天前的主题,其中的信息可能已经有所发展或是发生改变。
    apt-get install openssl

    注释掉Python-2.5.5/Modules/Setup.dist里的的ssl语句,然后

    ./configure --enable-ssl
    make
    make install

    在python里面可以成功import ssl,但update的时候总提示我ssl出错,这是有什么问题吗?

    附上报错代码的最后一部分:

    File "/home/huangz/desktop/google_appengine/lib/fancy_urllib/fancy_urllib/__init__.py", line 158, in connect
    'hostname mismatch')
    fancy_urllib.InvalidCertificateException: Host appengine.google.com returned an invalid certificate (hostname mismatch): {'subjectPublicKey': '0\x81\x9f0\r\x06\t*\x86H\x86\xf7\r\x01\x01\x01\x05\x00\x03\x81\x8d\x000\x81\x89\x02\x81\x81\x00\xe8\xf9\x86\x0f\x90\xfa\x86\xd7\xdf\xbdr&\xb6\xd7D\x02\x83xs\xd9\x02(\xef\x88E9\xfb\x10\xe8|\xae\xa98\xd5u\xc68\xeb\n', 'notAfter': 'Dec 18 23:59:59 2011 GMT', 'subject': ((('countryName', u'US'),), (('stateOrProvinceName', u'California'),), (('localityName', u'Mountain View'),), (('organizationName', u'Google Inc'),), (('commonName', u'www.google.com'),))}
    To learn more, see http://code.google.com/appengine/kb/general.html#rpcssl
    6 回复  |  直到 1970-01-01 08:00:00 +08:00
    elvis_w
        1
    elvis_w   2010-12-28 16:51:01 +08:00
    https://appengine.google.com/ 的SSL证书无法信任而出错
    ayanamist
        3
    ayanamist   2010-12-28 18:32:19 +08:00
    @Livid 好像没有必要修改,其实临时把系统的代理换掉就可以了。Win下设置Internet选项里的代理即可。默认使用系统的代理设置。
    elvis_w
        4
    elvis_w   2010-12-30 14:40:09 +08:00
    直接在appcfg.py里加上 --insecure 使用明文通信,不过安全性就......
    xds2000
        5
    xds2000   2010-12-31 01:49:46 +08:00
    遇到同样问题,得楼上的解答,把自己代理去掉即可
    huangz
        6
    huangz   2010-12-31 06:24:57 +08:00
    我后来发现是自己漏装了一个SSL包。

    ubuntu10.04上的具体步骤是:

    1.sudo apt-get install libssl-dev

    2.下载Python2.5源码,解压,cd /Python/Modules/,编辑文件Setup.dist,将ssl部分的注释去掉

    3.返回Python文件夹,./configure,make,make install

    这时Python2.5环境可以用了,python2.6可以用来上传gae app。

    不要装那个google帮助里提到的ssl包,我刚手贱装了下,现在gae又不能传了。
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2548 人在线   最高记录 5168   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 26ms · UTC 12:51 · PVG 20:51 · LAX 04:51 · JFK 07:51
    ♥ Do have faith in what you're doing.