V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
Vue.js
zhouxelf
V2EX  ›  Vue.js

Vue3 目前有已经在生产环境用的吗

  •  
  •   zhouxelf · 2020-11-24 14:01:29 +08:00 · 9184 次点击
    这是一个创建于 418 天前的主题,其中的信息可能已经有所发展或是发生改变。
    官方的库,Vue3 对应的 router 、vuex 我看目前还没发正式版,UI 组件库好像还没支持 Vue3 的正式版发布
    42 条回复    2020-12-22 15:39:31 +08:00
    ruoxie
        1
    ruoxie  
       2020-11-24 14:11:28 +08:00
    vscode 插件算生产环境吗
    fedfrank
        2
    fedfrank  
       2020-11-24 14:18:35 +08:00
    用了 composition api
    noe132
        3
    noe132  
       2020-11-24 14:21:47 +08:00
    没有 router vuex ui 组件库的 vue3 项目算 vue3 项目吗?如果算我给自己打个广告
    https://github.com/Firefox-Pro-Coding/iciba-translate-userscript
    crclz
        4
    crclz  
       2020-11-24 14:27:25 +08:00
    bootstrap-vue 好像兼容 vue3
    jjianwen68
        5
    jjianwen68  
       2020-11-24 14:30:02 +08:00
    quasar 使用 vue3 了吗
    DoneHee
        6
    DoneHee  
       2020-11-24 14:42:19 +08:00
    ant-design-vue+vue3+vue-router4+vuex4
    353943780
        7
    353943780  
       2020-11-24 16:46:57 +08:00
    全家桶其他大部分还在 RC 阶段,不敢用
    aristolochic
        8
    aristolochic  
       2020-11-24 19:39:29 +08:00
    @jjianwen68 Github 上置顶 Issue 说要明年
    似乎作者身体不太好,之前也说过去住院了
    然后还有就是希望借着兼容 Vue 3 的机会奠定出新版本的基础
    fewok
        9
    fewok  
       2020-11-24 22:19:04 +08:00
    欢迎使用 react 。。。
    beginor
        10
    beginor  
       2020-11-24 23:44:48 +08:00 via Android
    angular 11 路过
    agdhole
        11
    agdhole  
       2020-11-24 23:45:54 +08:00
    vuetify 年初出 RC
    lupkcd
        12
    lupkcd  
       2020-11-24 23:45:59 +08:00
    ant-design-vue 支持了,真香
    bojackhorseman
        13
    bojackhorseman  
       2020-11-24 23:52:43 +08:00 via iPhone
    目前在用 composition api
    anguiao
        14
    anguiao  
       2020-11-25 01:15:47 +08:00 via Android
    只用了 composition api,感觉还是很香的。等开新项目了,或许会试一试。
    dcoder
        15
    dcoder  
       2020-11-25 03:39:46 +08:00
    各种 UI component lib 都不支持 3...
    iamkun
        16
    iamkun  
       2020-11-25 08:34:10 +08:00 via iPhone   ❤️ 1
    Element UI 也支持 Vue3 了 欢迎尝鲜 https://github.com/element-plus/element-plus
    coloz
        17
    coloz  
       2020-11-25 09:46:02 +08:00
    都全面 TS 了,为什么不考虑下更成熟的 angular
    sam014
        18
    sam014  
       2020-11-25 09:47:31 +08:00
    vue3 + ant-design-vue(按需加载) + router,没有用 vuex,

    目前没碰到啥问题(不考虑 IE 问题不大)

    用 composition api 的话, 好像不支持 style scoped,这个蛮重要的
    ilskenyf
        19
    ilskenyf  
       2020-11-25 10:07:15 +08:00
    正在开发的项目算吗? https://ik.sg

    vue-i18n vue-router vuex vuex-persistedstate 用着没什么问题

    直接用上了 Vite, 有个小问题是路由 chunk 的时候 dev 可以,生产文件用 vite 的 Rollup 构建后不能用, 也没空去研究。
    gumang1988
        20
    gumang1988  
       2020-11-25 11:34:16 +08:00
    你们魔改了 ant-design-vue 么 ,现在最新版的收费。
    20498860
        21
    20498860  
       2020-11-25 11:41:02 +08:00
    @gumang1988 哪里说要收费啊?阿里这么大个厂不会收费的吧
    gumang1988
        22
    gumang1988  
       2020-11-25 11:49:08 +08:00
    @20498860 ant-design-vue pro
    20498860
        23
    20498860  
       2020-11-25 11:55:34 +08:00
    @gumang1988 这个不是阿里出的啊 这是二次封装的
    wunonglin
        24
    wunonglin  
       2020-11-25 12:06:24 +08:00
    angular11 路过
    coderabbit
        25
    coderabbit  
       2020-11-25 12:08:06 +08:00 via iPhone
    欢迎使用 react
    codingguy
        26
    codingguy  
       2020-11-25 14:26:09 +08:00
    @20498860 #21 ant-design-vue 不是阿里官方的,完全社区维护。
    Orainsink
        27
    Orainsink  
       2020-11-25 14:46:22 +08:00 via Android
    欢迎使用 react 17
    zedcoding
        28
    zedcoding  
       2020-11-25 14:58:56 +08:00
    不急哦 等着
    LoLeon
        29
    LoLeon  
       2020-11-25 15:04:57 +08:00
    打个广告, 一个 vue3 的 composition-api hook 库. 初次尝试开源, 还在摸索中.
    https://github.com/Awesome-Creators/vueposu
    20498860
        30
    20498860  
       2020-11-25 16:35:37 +08:00
    @codingguy 还真是社区的 幸好没用到公司里。。不然以后出问题了连背锅的都找不到
    jiangnan01
        31
    jiangnan01  
       2020-11-25 16:35:54 +08:00
    @gumang1988 没看到有写收费啊
    gumang1988
        32
    gumang1988  
       2020-11-25 18:13:05 +08:00
    @jiangnan01 pro Vue2 的版本不再继续更新只改 Bug,支持 Vue3 开始收费了。
    youla
        33
    youla  
       2020-11-25 18:23:38 +08:00
    我真的用了,信心满满的 ! 在重构之前的老项目。写了一天放弃了,回退。
    orzorzorzorz
        34
    orzorzorzorz  
       2020-11-25 19:04:43 +08:00
    从去年开始我就开始看主流三个库的更新状态,最后发现,angular 是真的在三年后等你(们)。人年龄越大,越喜欢填空,而不是花精力去选东选西。
    orzorzorzorz
        35
    orzorzorzorz  
       2020-11-25 19:06:08 +08:00
    @Orainsink 老哥如何处理 enzyme 对 react 17 的 adapter 的呢?
    Orainsink
        36
    Orainsink  
       2020-11-25 20:33:25 +08:00 via Android
    @orzorzorzorz 超纲了。我用了用 17 rc 版本,很多依赖报错,出现了一些和组件卸载相关的 bug 过后就放弃升级回滚了
    noe132
        37
    noe132  
       2020-11-25 22:06:07 +08:00
    @sam014 支持的,scoped css 目前必须要通过 vue-loader,才会处理 css 添加 id 。如果想直接 import tsx 文件就不行。我觉得之后可能会有支持 tsx 作为入口 的 vue-loader,因为实现起来并不复杂,相当于自动生成一个只有 script 和 style 标签的 vue 文件,然后让 vue-loader 处理
    tolking
        38
    tolking  
       2020-11-26 10:33:27 +08:00
    已经写了个小项目了,加上 vite 整体体验还是很好的。
    比较费心智的就是写 ‘.value’ ,偶尔会忘记;再者就是如何更好地抽离可复用的公共部分,要花些时间思考
    binaryify
        39
    binaryify  
       2020-11-26 14:53:34 +08:00
    @Orainsink ng 主要语法太丑了
    DreamStar
        40
    DreamStar  
       2020-12-22 15:03:20 +08:00
    @sam014 能请您讲述下按需加载怎么做的吗? 我按照 antdv2.0 的官方介绍安装了插件并配置了相关的配置文件 style 项也改成了 css,但是运行时依然会在控制台提示没有按需引入.期待您的回复
    sam014
        42
    sam014  
       2020-12-22 15:39:31 +08:00
    @DreamStar 使用推荐的 babel-plugin-import 方式
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2388 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 23ms · UTC 09:46 · PVG 17:46 · LAX 01:46 · JFK 04:46
    ♥ Do have faith in what you're doing.