V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
测试工具
SmokePing
IPv6 访问测试
dototototo
V2EX  ›  宽带症候群

我服气了,交换机和路由器死活连不上

  •  
  •   dototototo · 172 天前 via Android · 1660 次点击
    这是一个创建于 172 天前的主题,其中的信息可能已经有所发展或是发生改变。
    某鱼买了个 QNAP M408 4C 的交换机,东西是好东西,本身也没什么问题,但是死活和我的 AX86U 连不通,这两货难道八字不合不成?



    怕大家误会我先说几点:

    1. 主路由器拨号,路由器 LAN 口接墙上网线面板,面板网口单独测试是通的

    2. 面板网口接线到交换机,不通,交换机该口状态灯不亮

    3. 网口面板接线到实际用网设备(用的是接交换机的同一根线),网通

    4. 将交换机和面板网口连接的线改为交换机带某个副路由器,路由器和交换机可正常通信

    5. 将网络改为主路由器——副路由器——交换机,可以通(同一个面板,交换机同一个网口,用同一根线)



    所以我是真服气了,线没问题,设备都能用,但是只要路由器和交换机一接,交换机和路由器这路就不通了,状态灯都不亮的那种,当真是八字不合呗……实在是没办法了,有没有人有这方面经验的,分享下……
    16 条回复    2021-12-01 02:14:18 +08:00
    Chingim
        1
    Chingim  
       172 天前
    控制变量, 就路由器和交换机直接连, 别带别的有的没的
    xxb
        2
    xxb  
       172 天前 via iPhone
    给拓扑图清晰些。
    网管型还是傻瓜交换机?
    kokutou
        3
    kokutou  
       172 天前
    二手交换机到手, 至少进去看看配置吧...
    dototototo
        4
    dototototo  
    OP
       172 天前 via Android
    @xxb 网管型呀,不过也不需要多设置什么就能用就是了,完整测试了两种情况:
    光猫桥接——路由器拨号——(超 5 )路由器 LAN 接墙上面板——(超 6 )交换机——(超 6 )设备若干
    后面为了解决问题改成了光猫桥接——路由器拨号——(超 5 )路由器 LAN 接墙上面板——(超 6 )接副路由器 WAN 口——(超 6 )副路由器 LAN 口接交换机——(超 6 )设备若干
    第一种时交换机与面板接口的网口会无状态灯,第二种时一切正常。
    dototototo
        5
    dototototo  
    OP
       172 天前 via Android
    @kokutou 交换机是二层的,已经恢复出厂设置,本体功能正常,网口正常
    dototototo
        6
    dototototo  
    OP
       172 天前 via Android
    @Chingim 能控制的地方尽量控制了,直接连接测试因为要拆很多东西比较麻烦,所以还没做,现在我发现的问题是,路由器——面板——交换机不行,路由器——面板——副路由器——交换机行,你说奇怪不奇怪……
    HawkinsSherpherd
        7
    HawkinsSherpherd  
       172 天前
    考虑一下线材的兼容性?我想到了一个陈旧的情况:不支持自动翻转的年代,异类设备之间的连接要用交叉线,同类设备要用直通线。也许某个设备不支持自动翻转功能,而墙里埋的是直通线?
    nyanyamilk
        8
    nyanyamilk  
       171 天前
    主路由器再重置下 彻底点
    blessme
        9
    blessme  
       171 天前
    我猜你的交换机设置了 vlan ,所以,你自己进去看看配置吧,恢复一下默认出厂配置。
    acbot
        10
    acbot  
       171 天前
    @HawkinsSherpherd 我个人也这样觉得
    dototototo
        11
    dototototo  
    OP
       171 天前 via Android
    @HawkinsSherpherd @nyanyamilk @blessme @acbot 感谢各位帮助,交换机和路由器都是有重新设置的,不存在问题,最终我发现是墙内网口接线的第八根线松动所致,不过现在想来还是奇怪,线只这一根是松的,按我理解的应该是能降速运行才是,结果却是用电脑和副路由器测试都可以上网,唯独交换机是不行的😂
    Damn
        12
    Damn  
       171 天前
    @dototototo 又不是所有的设备都能降速运行,前两年接触过一些 X86 服务器,网口就只能是是 1000mbps ,你这个交换机大约就是一样的情况了呗。
    HawkinsSherpherd
        13
    HawkinsSherpherd  
       171 天前
    @dototototo 也许是线的缺陷让设备无法翻转端口,从而连连都连不上,交换机跟路由器不是同一类设备,要用交叉线或支持自动翻转(这个基本是个现代网络设备都能,不过在这种情形下这个陈旧的故障再度显现出来了)。说到速度协商的话,许多比较老的设备不支持 NBASE-T ,没有 2.5g 跟 5g 这样的中间速率支持,只好协商到 1g 。NBASE-T 是一个新标准,它的出现更多是为了在老网线上跑到更高的速率。
    dototototo
        14
    dototototo  
    OP
       171 天前 via Android
    @Damn 交换机是支持的呀
    dototototo
        15
    dototototo  
    OP
       171 天前 via Android
    @HawkinsSherpherd 我想了下,如果是您说的这个问题的话倒是有可能,面板那边我是没有特别留意,但是接路由器那头我记得很清楚是按照 568B 接的,所以想来面板这边也是才对。
    速度协商交换机这边倒是支持挺全的,可惜 AX86U 还是个千兆水平,先这么用着吧,内网舒服就行😂
    flynaj
        16
    flynaj  
       168 天前 via Android
    可能是不支持自动反转,一头用 568a,另外一头用 568b
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   3060 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 22ms · UTC 01:01 · PVG 09:01 · LAX 18:01 · JFK 21:01
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.