V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
Distributions
Ubuntu
Fedora
CentOS
中文资源站
网易开源镜像站
ziyouhua
V2EX  ›  Linux

请教大佬一个 ubuntu 运行 dpkg 的问题

  •  
  •   ziyouhua · 136 天前 via Android · 728 次点击
    这是一个创建于 136 天前的主题,其中的信息可能已经有所发展或是发生改变。

    我的 vps 是 ubuntu 系统,但无法安装 dpkg ,许多简单的系统升级命令都运行不了,都出现:

    5 条回复    2023-10-09 06:34:43 +08:00
    hsfzxjy
        1
    hsfzxjy  
       136 天前 via Android
    出现啥
    ziyouhua
        2
    ziyouhua  
    OP
       136 天前 via Android
    都出现:

    E: dpkg was interrupted, you must manually run \'dpkg --configure -a\' to correct the problem


    它好像说是要运行 dpkg --configure -a ,但运行了 dpkg --configure -a ,又出现

    dpkg: error: parsing file \'/var/lib/dpkg/updates/0001\' near line 0:
    end of file after field name

    请问怎么搞?
    NessajCN
        3
    NessajCN  
       135 天前
    sudo rm /var/lib/dpkg/updates/*
    sudo apt update && sudo apt upgrade
    ziyouhua
        4
    ziyouhua  
    OP
       135 天前 via Android
    谢谢,ChatGPT 都解决不了的你解决了
    levenwindy
        5
    levenwindy  
       134 天前 via Android
    一般来说,报错命令 去谷歌就行了
    关于   ·   帮助文档   ·   博客   ·   API   ·   FAQ   ·   我们的愿景   ·   实用小工具   ·   901 人在线   最高记录 6543   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 28ms · UTC 21:58 · PVG 05:58 · LAX 13:58 · JFK 16:58
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.