首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX  ›  程序员

LNMP 环境,php.ini 修改之后为什么不生效

  •  
  •   passion336699 · 2016-04-05 17:33:57 +08:00 · 16248 次点击
    这是一个创建于 1339 天前的主题,其中的信息可能已经有所发展或是发生改变。

    主要是改一下上传文件大小,重启过 nginx 和 php5-fpm 了,怎么还是原来的默认值 2M?

    38 回复  |  直到 2016-04-06 11:25:52 +08:00
        2
    passion336699   2016-04-05 17:38:47 +08:00
    @linar client_max_body_size ,post_max_size, upload_max_filesize 这些我都改过了,也都重启了,还是 2mb
        3
    kasp   2016-04-05 17:49:48 +08:00   ♥ 1
    使用 phpinfo 看是否生效?
        4
    ZGLHHH   2016-04-05 17:52:22 +08:00 via Android   ♥ 1
    service php-fpm restart
        5
    hiboshi   2016-04-05 18:07:58 +08:00
    /etc/init.d/php-fpm restart
        6
    hancc   2016-04-05 18:18:28 +08:00 via Android   ♥ 1
    配置文件好像在 /etc/的某个目录里面
        7
    ETiV   2016-04-05 18:25:19 +08:00   ♥ 1
    先看 phpinfo 里的 php.ini 的路径, 也许你改的不是 PHP 读的那个
        8
    rogerlee   2016-04-05 18:37:38 +08:00   ♥ 1
    清浏览器缓存试试
        9
    passion336699   2016-04-05 18:43:26 +08:00 via Android
    不是的,我改的就是 phpinfo 里面的 php.ini , nginx,phpfpm 已经都重启过了
        10
    passion336699   2016-04-05 18:43:39 +08:00 via Android
    T T
        11
    herozzm   2016-04-05 18:44:32 +08:00 via Android
    Nginx 里面也会现在上传大小
        12
    herozzm   2016-04-05 18:44:50 +08:00 via Android   ♥ 1
    限制
        13
    passion336699   2016-04-05 18:52:49 +08:00 via Android
    上面不说说过了,就那个 clinebox ,我也修改了啊,后台报的错就是超过了 php 配置的上传文件最大值,但是 php.ini 修改到 30mb,在 phpinfo 里面输出的还是 2mb
        14
    passion336699   2016-04-05 18:54:13 +08:00 via Android
    phpfpm restart 我肯定重启了的啊。。。
        15
    passion336699   2016-04-05 18:55:07 +08:00 via Android
    fpm/php.ini 和 cli/php.ini 我都改了,并不起作用,phpinfo 里面还是原来的默认值 2 8 128
        16
    ZGLHHH   2016-04-05 19:11:59 +08:00   ♥ 1
    LNMP 的 php.ini 路径:
    /usr/local/php/etc/php.ini
        17
    vus520   2016-04-05 19:16:06 +08:00   ♥ 1
    1 , web 里丢一个 phpinfo ,看看 php.ini 的位置
    2 ,确认 nginx 的配置是不是也修改了
        18
    passion336699   2016-04-05 19:31:11 +08:00
    @ZGLHHH 这路径下面没有 php,etc 里面也是空的呀,ubuntu14.04 root 登录
        19
    passion336699   2016-04-05 19:34:06 +08:00
    @vus520 nginx 修改了,就是那个客户端的最大值吧,我不改会报 413 错误,我已经改到 100MB 了,传文件的时候,超过 2MB,后台给我报的错就是 '超出 php 配置中上传文件最大值',phpinfo 里面的位置是 /etc/php5/fpm/php.ini ,我改的也就是这个 php.ini
        20
    kiwi95   2016-04-05 19:43:53 +08:00   ♥ 1
    一般来说是你改错了 php.ini 文件, php -i 看看 php 用的是那个 ini 文件
        21
    passion336699   2016-04-05 19:51:21 +08:00
    @kiwi95
    PHP Version => 5.5.9-1ubuntu4.14

    System => Linux iZ94bjkhoxxZ 3.13.0-65-generic #106-Ubuntu SMP Fri Oct 2 22:08:27 UTC 2015 x86_64
    Build Date => Oct 28 2015 01:31:23
    Server API => Command Line Interface
    Virtual Directory Support => disabled
    Configuration File (php.ini) Path => /etc/php5/cli
    Loaded Configuration File => /etc/php5/cli/php.ini
    Scan this dir for additional .ini files => /etc/php5/cli/conf.d

    这个我也改过了.
        22
    ETiV   2016-04-05 19:56:00 +08:00 via iPhone
    CLI 什么鬼…
        23
    passion336699   2016-04-05 19:58:05 +08:00
    @ETiV 不知道什么鬼啊,但是我 phpinfo()里面输出的是
    Configuration File (php.ini) Path /etc/php5/fpm
    Loaded Configuration File /etc/php5/fpm/php.ini
    这样的啊
        24
    ETiV   2016-04-05 20:04:16 +08:00   ♥ 1
    你写一个 info.php
    放到 HTTP 可以访问的路径下, 然后去访问他, 看这个页面里, php.ini 在哪.
    然后再从服务器上面去改这个文件, 改完后重启 php-fpm

    不要用从命令行里跑这个文件.
        25
    passion336699   2016-04-05 20:09:12 +08:00
    @ETiV 不是吧,现在还给我将 phpinfo,我都说了这么多楼了,你自己看,你说的我都做过了.http://lovchun.com/
        26
    Bardon   2016-04-05 20:46:45 +08:00
    奇葩的 lnmp
    楼主,提问前,准备如下
    修改的文件路径,具体修改了什么
    phpinfo 整个页面信息

    楼主用哪个发行版?建议去对应发行版的 wiki 页面去过一边,为什么会用到 lnmp ?

    别认为自己某个步骤没错,就不说,信息提供尽量完全点,你这样一问一答的形式真的让人很蛋疼。
    建议去 linux 各发行版的 bugzilla ,看看人家是怎么提问的。
        27
    Bardon   2016-04-05 20:47:58 +08:00
    再说,你这应该去 lnmp 官网去问,人家对 lnmp 的结构熟悉。
        28
    realpg   2016-04-05 22:14:01 +08:00   ♥ 1
    俩地方,一个是 conf.d, 一个是 fpm pool 这俩地方都能覆盖设置
    最省事的办法
    cd /etc/php5
    grep -R "post_max_size" .
    grep -R "upload_max_filesize" .
    挨个去确认吧
        29
    aprikyblue   2016-04-05 22:16:32 +08:00   ♥ 1
    26L+1
    请尽量提供完整的信息
        30
    darluc   2016-04-05 22:33:50 +08:00   ♥ 1
        31
    linescape   2016-04-05 22:38:25 +08:00   ♥ 1
    改上传大小记得同时改允许的最大的 POST 大小。。
        32
    passion336699   2016-04-05 23:24:45 +08:00
    @darluc 感谢 30L 大兄弟...在 www.conf 最后加上

    php_value[memory_limit] = 96M
    php_value[max_execution_time] = 120
    php_value[max_input_time] = 300
    php_value[php_post_max_size] = 25M
    php_value[upload_max_filesize] = 25M

    就解决了,现在 phpinfo 里面的值也改变了.看来应该是这个配置覆盖掉了 php.ini 的原因
    T_T 终于解决了
        33
    passion336699   2016-04-05 23:25:42 +08:00
    谢谢大伙...搞了好半天了 @_@
        34
    cst4you   2016-04-06 00:33:34 +08:00
    奇葩的一键包.
        35
    ivanfjz   2016-04-06 09:36:49 +08:00
    觉得将来极有可能会经历这样子的问题, MARK 下
        36
    lijinma   2016-04-06 11:04:51 +08:00
    果然 php-fpm 的配置会覆盖 php.ini
        37
    passion336699   2016-04-06 11:24:38 +08:00
    @cst4you 不是一键包...php,mysql,nginx 我都是分开 apt-get install 的....php 的一些扩展什么我也是安装完 php5-fpm 之后再逐个装的
        38
    passion336699   2016-04-06 11:25:52 +08:00
    @lijinma 是的 那个优先级高于 php.ini,然后 php-fpm 的配置都是默认的,所以改了 php.ini 都没用
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   3547 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 29ms · UTC 05:23 · PVG 13:23 · LAX 21:23 · JFK 00:23
    ♥ Do have faith in what you're doing.