首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
Distributions
Ubuntu
Fedora
CentOS
中文资源站
网易开源镜像站
V2EX  ›  Linux

Ubuntu 普通升级也能把登录升挂?

  •  
  •   stardust21 · 2016-04-05 23:48:02 +08:00 · 4511 次点击
    这是一个创建于 1292 天前的主题,其中的信息可能已经有所发展或是发生改变。

    Ubuntu14.04 ,没做什么操作,好像就升级了下, ssh 和 tty 都登录不进去了,用 XUbuntu 的 liveCD 进入看 auth.log,都是

    PAM unable to dlopen(pam.unix.so):/lib/security/pam.unix.so: cannot open shared object file: No such file or directory
    PAM adding faulty module: pam_unix.so
    

    看了下,确实没有 /lib/security/目录, XUbuntu 倒是有这个目录,但是文件名不一样,直接拷贝过去改名,也没有用。有谁也遇到过这种问题么?解决不了的话只能重新启一台机器重新部署了,不过还是想知道这种情况是怎么发生的。

    个人一直用 Ubuntu 桌面版,除了内部错误,没有出过大的问题。 Ubuntu 的 server 这么容易挂么,大家 server 都用的什么版本?

    32 回复  |  直到 2016-04-07 11:26:50 +08:00
        1
    likuku   2016-04-06 00:06:35 +08:00
    手里一堆 debian 7 server 路过
        2
    xuan880   2016-04-06 00:07:55 +08:00 via Android
    服务器,桌面每天都是无脑升级,没出现过问题,你看一下 shell 的操作日志,是不是删错了文件。
        3
    stardust21   2016-04-06 00:13:07 +08:00
    @xuan880 服务器也每天升级……
    live cd 的 vnc 太慢,下次再看看日志,应该是没有删什么东西的。
        4
    stardust21   2016-04-06 00:13:45 +08:00
    @likuku 也准备用 debian7 了,稳定最重要~
        5
    11138   2016-04-06 00:33:47 +08:00   ♥ 1
    “好像”?“应该”? 这样说没人可以帮到你啊。
    你应该认真找出出问题之前的操作日志,然后才能判断和解决问题。关键是下次可以避免同样的事情发生。
    系统就算多么稳定,经过人为“好像”“应该”的操作之后,会变得很脆弱。
        6
    stardust21   2016-04-06 01:05:51 +08:00
    @11138 说的很对,我重新挂了 livecd 把历史查了下,确实没删什么重要的东西,只有升级。
    [email protected]:~$ sudo cat /media/xubuntu/XXXXXXXX/root/.bash_history |grep "apt-get"
    sudo apt-get install pip
    sudo apt-get install python-pip
    apt-get install vim
    sudo apt-get install htop
    apt-get install supervisor
    apt-get install fail2ban log watch gamin
    apt-get install fail2ban
    apt-get install screnn
    apt-get install screen
    apt-get update
    apt-get upgrade -y
    apt-get install redis-server screen git curl
    apt-get install asciidoc
    apt-get install fuse
    apt-get install tmux
    apt-get installlibssl
    apt-get install libssl
    apt-get install libssl*
    apt-get -f install
    apt-get upgrade
    sudo apt-get install libssl1.0.0 libssl-dev
    apt-get install libcrypto
    apt-get install openssl
    apt-get install -y lsb
    apt-get update
    apt-get upgrade
    apt-get install libssl-dev
    apt-get upgrade
    [email protected]:~$ sudo cat /media/xubuntu/XXXXXXXX/root/.bash_history |grep rm
    rm -rf megatools-1.9.97/
    rm 1.9.97.tar.gz
    rm ~/.megarc
    rm downurl.php\?release\=Ubuntu
    rm serverspeederbin.txt
    [email protected]:~$
        7
    seki   2016-04-06 01:26:53 +08:00
    会不会是 libssl , 14.04 依赖于 1.0.1 ……
        8
    realpg   2016-04-06 01:51:59 +08:00
    上百台 ubuntu server , 12.04 14.04 都有 还有少量非 LTS 的 15.10
    全部无脑全自动 dist-upgrade 从未出过问题
    而且所有生产环境 除非一些特定有需求不升级的服务器,都是在 lts 版本间直接跨版本升上来的,都没出过问题
        9
    11138   2016-04-06 02:11:03 +08:00
    有时候硬盘故障也会丢失部分文件,但系统表面上还是看似正常。
        10
    Andy1999   2016-04-06 02:19:34 +08:00 via iPhone
    默默喊一句 CentOS 大法好
        11
    Tink   2016-04-06 03:28:58 +08:00 via iPhone
    你们服务器居然都敢全自动升级......

    我 server 从来不升级
        12
    wwhc   2016-04-06 05:38:33 +08:00
    Gentoo 服务器几周前自动升级后 cron 不工作了,检查 emerge 记录:

    * Messages for package sys-libs/pam-1.2.1:

    * Some software with pre-loaded PAM libraries might experience
    * warnings or failures related to missing symbols and/or versions
    * after any update. While unfortunate this is a limit of the
    * implementation of PAM and the software, and it requires you to
    * restart the software manually after the update.
    *
    * You can get a list of such software running a command like
    * lsof / | egrep -i 'del.*libpam\.so'
    *
    * Alternatively, simply reboot your system.

    不过 ssh 并没有受到影响。
        13
    4679kun   2016-04-06 07:21:39 +08:00   ♥ 1
    我服务器跑 arch 天天滚 也没出问题
        14
    des   2016-04-06 07:34:58 +08:00 via Android
    @4679kun 服务器跑洗发水??你隔两个星期不滚试试
        15
    kn007   2016-04-06 07:43:26 +08:00
    CentOS 6 一直直接无脑 yum update...

    没有问题
        16
    Laobai   2016-04-06 07:56:40 +08:00 via Android
    Server 还是用 centos 省心
        17
    4679kun   2016-04-06 07:57:13 +08:00
    @des 一个月滚也没事 滚之前看看公告就行
        18
    Neveroldmilk   2016-04-06 08:15:57 +08:00
    有些东西不兼容吧?我的 Ubuntu14.04 LTS 也这样,一升级就废了,只有回滚。
        19
    stardust21   2016-04-06 09:55:22 +08:00
    @seki 准备装 rui 速的,结果提示 libssl 有问题,最后看了下是 1.0.0 版本的,没有手动降级过。 libssl 会影响到 pam 吗?
        20
    jsthon   2016-04-06 10:47:42 +08:00 via Android
    我经常合盖挂起后就再也无法唤醒了…

    还有几次无法顺利关机…

    有次关了一晚上还没成功…第二天早上还在关…

    Ubuntu 15.10 Desktop For Dell XPS 13
        21
    jsthon   2016-04-06 10:51:40 +08:00 via Android
    差点忘了回答…

    Server 用的 Ubuntu 14.04...

    内核不敢随便升级,曾经挂掉过…
        22
    vonnyfly   2016-04-06 11:15:06 +08:00
    Ubuntu 典型的容易滚挂,没事少升级。。。
        23
    seki   2016-04-06 11:17:42 +08:00
    @stardust21 不好意思,我把 openssl 和 libssl 的版本记混了,不是 libssl 的问题嗯……
        24
    bubbles   2016-04-06 12:26:14 +08:00
    Archlinux 笑而不语。天天滚都没事。
        25
    csx163   2016-04-06 12:29:57 +08:00
    确认没改过官方源么
        26
    liaohongxing   2016-04-06 14:51:11 +08:00
    滚了几年的 ubuntu server 也没滚挂过 。你怎么目录都 滚掉了呢。纳闷。
        27
    stardust21   2016-04-06 15:38:57 +08:00
    @csx163 没有, vps 上官方的速度还可以
        28
    stardust21   2016-04-06 15:39:19 +08:00
    @liaohongxing 我也很纳闷
        29
    dorentus   2016-04-06 16:40:49 +08:00
    apt-get install libssl*
    apt-get -f install

    这个中间肯定发生了什么事情……
        30
    zhouxuchen   2016-04-07 02:24:48 +08:00
    Ubuntu 升级一次就当重新学习了 233
        31
    taobeier   2016-04-07 10:23:52 +08:00
    手里一堆服务器都是 CentOS 和 Debian 的~ 不过没事别乱升级~ 我的看法和 @dorentus 一样, 你那两个命令之间应该是发生过什么吧 .
        32
    stardust21   2016-04-07 11:26:50 +08:00
    @taobeier 第二条命令是根据提示输的,不太记得请中间发生什么了~
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   824 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 25ms · UTC 21:59 · PVG 05:59 · LAX 14:59 · JFK 17:59
    ♥ Do have faith in what you're doing.