V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX 提问指南
overthemoon
V2EX  ›  问与答

升级 jdk17 的必须的吗?

  •  
  •   overthemoon · 104 天前 · 1993 次点击
    这是一个创建于 104 天前的主题,其中的信息可能已经有所发展或是发生改变。

    做的外包项目,在原来 jdk8 的项目基础上做二次开发,甲方要求升级到 jdk17 ,而我们工期还很紧,项目里面还用到很多开源的框架,换成 jdk17 后各种报错,找什么借口不升级 jdk17 好呢

    第 1 条附言  ·  102 天前
    升级完成!外包真难,电脑配置不行还不能连外网,什么都得和甲方要,要不是今年困难,谁愿意进外包!
    31 条回复    2022-08-17 16:32:10 +08:00
    julyclyde
        1
    julyclyde  
       104 天前   ❤️ 6
    你这是给甲方和整个行业添麻烦
    仅仅是因为你们懒得学习
    oneisall8955
        2
    oneisall8955  
       104 天前 via Android
    加两周的工期,够升级了吧?
    Bingchunmoli
        3
    Bingchunmoli  
       104 天前 via Android
    不是旧版本依赖的话,升级 17 没有改动,旧版本依赖升级的话就看废弃方法如何迁移呗
    knightdf
        4
    knightdf  
       104 天前
    升级毫无问题
    adoal
        5
    adoal  
       104 天前 via iPhone
    签合同之前没讲清楚?
    xscit
        6
    xscit  
       104 天前 via Android
    甲方思想这么先进吗?🐶
    semoon
        7
    semoon  
       103 天前
    这不正是 java 牛逼的地方么。。。

    我们有 jdk6 无修改直升 jdk11 的经验 23333
    bk201
        8
    bk201  
       103 天前   ❤️ 1
    加钱加工期呗。既然是升级,那能找什么借口
    overthemoon
        9
    overthemoon  
    OP
       103 天前   ❤️ 6
    @julyclyde 什么麻烦?还整个行业,这个行业就是因为你们这些事逼的出现还变得麻烦,仅仅因为你们爱装
    overthemoon
        10
    overthemoon  
    OP
       103 天前
    @oneisall8955 第一次进外包,不懂
    overthemoon
        11
    overthemoon  
    OP
       103 天前
    @Bingchunmoli 我们开源组件多,哎
    overthemoon
        12
    overthemoon  
    OP
       103 天前
    @xscit 一点也不先进,还不是 jdk8 的代码写来写去
    a33291
        13
    a33291  
       103 天前
    貌似现在都喜欢刷版本号 😂
    dcsuibian
        14
    dcsuibian  
       103 天前
    跟他说加工期,加了工期的话就没啥借口了。

    说实话我感觉这思想挺先进的,一般都是程序员激进而领导、甲方保守。程序员本来就是要终身学习的。
    Jooooooooo
        15
    Jooooooooo  
       103 天前
    加钱啊.
    wbrobot
        16
    wbrobot  
       103 天前
    docker
    yanzhiling2001
        17
    yanzhiling2001  
       103 天前
    jdk8 用 docker 封装好,能保证 稳定运行 / 无缝迁移 即可。

    甲方掏钱他当然有话语权,告诉他实情,让加钱就好了。

    不愿意加钱? 那就继续 J8 好了,不耽误用。
    overthemoon
        18
    overthemoon  
    OP
       103 天前
    @dcsuibian 甲方假积极,用的技术都很旧,非得升个 jdk17
    Bingchunmoli
        19
    Bingchunmoli  
       103 天前
    省事一点就是更新依赖版本,哪里报错改哪里,不省事一点就是不更新依赖版本,把依赖二次包装适配
    cvbnt
        20
    cvbnt  
       103 天前 via Android
    反正 Spring6 开始就最低支持 jdk17 了,实在不行就当学习了
    123zouwen
        21
    123zouwen  
       103 天前
    甲方让你升级还不升级啊 很多人还想用新版本结果公司 /甲方不让的
    otakustay
        22
    otakustay  
       103 天前   ❤️ 2
    那你这么有志气,觉得甲方太爱装,你就不赚这钱呗,背挺直点
    overthemoon
        23
    overthemoon  
    OP
       103 天前
    overthemoon
        24
    overthemoon  
    OP
       103 天前
    @cvbnt 要的,学习中
    overthemoon
        25
    overthemoon  
    OP
       103 天前
    @123zouwen 看情况吧
    overthemoon
        26
    overthemoon  
    OP
       103 天前
    @otakustay 我没这样说喔,1 楼那种人爱上纲上线
    ihacku
        27
    ihacku  
       103 天前
    可以试下这个
    EMT4J——让 Java 应用升级更轻松 https://mp.weixin.qq.com/s/9pKGVctSd-phrV4sKqqfxA
    Bingchunmoli
        28
    Bingchunmoli  
       103 天前
    @ihacku 好东西,就是目前用的人可能不是很多
    neptuno
        29
    neptuno  
       103 天前 via iPhone
    加钱就行
    julyclyde
        30
    julyclyde  
       103 天前
    @overthemoon 坚持旧 JDK=只能坚持旧 GC 和各种旧库了
    然后就需要坚持重复解决世界上早已解决过的问题
    overthemoon
        31
    overthemoon  
    OP
       102 天前
    @julyclyde OK ,大佬受教了
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   3517 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 45ms · UTC 04:41 · PVG 12:41 · LAX 20:41 · JFK 23:41
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.